New concept added not found in dropdown menu for alternative

I am trying to add a new concept to annotate for in a project. The new concept is added and appears correct for the first instance.

A following attempt to use the new concept as an alternative for another instance fails. The concept cannot be found in the drop down by either the string it’s named for or the CUI assigned. Furthermore it cannot be added again, triggering a log message too.

Reimporting concept DB after adding did not help.

MedCat Version 2.3.8.

The new concepts added with the GUI appear in the concept database, but do not appear in the dropdown even after importing the database.

Under tasks I can see some previous errors in importing the CDB. After importing CDB and waiting to see the process lock then the entry disappear I return to the trainer project and still cannot lookup the new added concept. I am also unable to add the concept again.

The new concepts added are being found in subsequent documents despite the lookup not showing them.

this bug is fixed in the latest release, tag v2.5.0.

I’d also caution against using this feature unless the ontology really doesn’t support what you’re looking for. Creating new concepts means the annotations and downstream model becomes specific to that project and then probably won’t be used for anything else.

What part of SNOMED CT or UMLS is not sufficient for your use case?

Thanks, I will see about upgrading it.

I’m trying to annotate for specific genetic mutations.
There are some snomed concepts that exist that are close but not specific enough.

Ideally each pattern of
C282Y\C282Y Homozygous
H63D\H63D Homozygous
C282Y\H63D Heterozygous

Snomed CT has carrier of HFE gene, but this does not tell me hetero or homo.
It has individual hetero/homo, and genetic mutation.
There are specific codes for other known mutations with hetero/homo in a single term but one does not exist for hemochromatosis.

Importantly, there is no way to annotate for the particular position, for example to differentiate 63 from 282. These are important concepts for this project.

Cool - got it.

This might be a good case for authoring of new terms within SNOMED CT

I don’t think that issue is fixed (MCT v 2.5.0).
I just tried to “Add new concept” and then when I tried to search it doesn’t appear in a lookup. Can anyone else confirm this?

Just checking you see existing concepts appearing in the dropdown?

Yes we do see existing concepts in the dropdown.

thanks - fixed the bug. Error reporting should be better now also. Patched container images are building now. I’ll update the docker-compose.yml once complete

Snomed doesn’t have full detail on all concepts, and it would be better the concept is defined in snomed first (ie. Format Authoring into SNOMED) rather than making custom concepts.

In my opinion, specifics of genetic mutations is better to be annotated using an alternative system designed for genetics like OMIM or HPO.

FYI, we have done this before in stroke when a missing “Malignant MCA syndrome” was authored together with a SNOMED Terminologist and accepted into SNOMED releases.

If you can’t wait, better to keyword search /regex as last step for the mutation than to create custom terms that never merge in future editions.

v2.5.1 appears to have the same problem.

Adding a new concept seems to throw a non descriptive error that is in a log file I cannot find.
Readding the same concept throws an error pointing to the previous one occupying the name/cui code.
Lookup fails to find previously added concepts.
There is also a bug not showing the name of a CUI that has been added where the online training annotates for it in subsequent documents.

To be clear the “add term” >>> lookup is failing.

Secondly, trying to use UMLS at 3.9gb unzipped throws an error over the network.
Locally uploading it throws 413 Request entity Too large nginx.

UMLS has the concepts that meet my immediate needs, though as I go through the documents the need for more specific concepts may arise.